Support Center

How to fix Android build error due to Paypal plugin

Last Updated: Dec 13, 2016 01:34PM EET

The following error is showing in the terminal on  ionic build android:

Cause

The  barcodescanner sets the  minSdkVersion to 15 whereas the paypal  plugin needs a minSdkVersion equal to16.

Fix

Open the barcodescanner.grandle file under the project/plugins/phonegap-plugin-barcodescanner/src/android path and change the minSdkVersion to 16. Finally, add the Android platform and build it.

Contact Us

a2a0cbd00b7dcd034f6f4d9b56d741db@appseed.desk-mail.com
https://cdn.desk.com/
false
desk
Loading
seconds ago
a minute ago
minutes ago
an hour ago
hours ago
a day ago
days ago
about
false
Invalid characters found
/customer/en/portal/articles/autocomplete